WiseLoop PHP Javascript Obfuscator 4.0.0
Anti-Theft Protection for JavaScript Source Code
Installation

Requirements

  • Apache Web Server 2.0.0 or above
  • PHP 5.0.0 or above

Step 1: Package Directory

Copy the entire /php-javascript-obfuscator directory on your web server. The directory is included in the downloaded archive.
You should have the following directories:

  • /php-javascript-obfuscator/bin
  • /php-javascript-obfuscator/cache
  • /php-javascript-obfuscator/config
  • /php-javascript-obfuscator/repository

Step 2: Cache Directory Setup

Make sure that the /php-javascript-obfuscator/cache directory is writable.

At this point, the installation is complete.
Although just by installing the obfuscator offers the possibility to protect JavaScript source code directly without any other configuration settings, in order to benefit of the full feature set, it is better to create some obfuscation environments that will be used by your applications. Please refer to the Environment Setup section to find out how to configure obfuscation engine.

 All Data Structures Functions Variables